Python is v3.3.1 which is not supported by gyp

“Python is v3.3.1 which is not supported by gyp”

Node only runs with Python versions >= 2.5.0 & 3.0.0. Here half way through the run we can see this!

Python_versions

So we need to fix this Python install to run from version 3.0.0 (I know I have both a new and old version installed as I upgraded sometime ago).

Python_install_windows_folders

The new one v3.3.1 so let’s downgrade to the supported version. Keywords: “node downgrade python to 2.7”.I’ll just double check my System PATH variables..

What_version_of_Python_is_running

Let’s try again.

System_PATH_variables

Still a few errors, reducing them though. Keyword “node-gyp rebuild error”. https://npmjs.org/package/node-gyp

Correct_version_of_Python

Gyp_error

Npm_install_gyp

Done.